Announcement

Collapse
No announcement yet.

Server Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Try to change ur subserver
    im fine to play btw
    Ign : Dr. VerdantGate

    Comment


    • #17
      Originally posted by BlitzCrank08 View Post

      I used to play with 1mbps from 2014-2015, never experienced any lag, not until ubisoft took over the game.
      exactly even using data connection can run this gane without any lags, now its impossible lmao
      IGN : DRAYFUS


      JOIN MY GIVEAWAY! GO TO THE GIVEAWAY SUBFORUM AND APPLY THERE! GOODLUCK!




      IM JUST A SIMPLE GROWTOPIAN WHO IS STRIVING TO BE A PRO

      AND DOING ALL WORK JUST TO BE RICH AND ALSO HELP NOOBS!

      Comment


      • #18
        Originally posted by Knocha View Post

        10 Mbps is bad
        Then how can i play Call of duty with good ping no delay 8 ms then Pubg 8 ms stable green then when it comes to growtopia so lag and delay
        The unseen blade is the deadliest
        sigpic

        Comment


        • #19
          Tbh it doesn't matter whether you have 10 or 100 Mbps of Up/Downstream speed if the server you are connecting to is not powerful enough to handle certain amount of traffic, or is already full, or host located too far away from your actual location.
          in Growtopia case, i'd say there are significant performance drop compared to a year ago. The perfect example for what i mean can be seen by entering a maxed out player count world such as BUYDAILYQUEST.
          The team should have aware of this performance issue, and i hope something can be done to fix it.

          Comment


          • #20
            Hey! Will be merging this with other thread with similar topics and moving it to the Bugs and Glitches Sub-forum since it's about the server issues

            ~ HuffleWitz

            Comment

            Working...
            X