Hi all,

Due to an update we had to proceed with, we won't be able to continue the support for Open GL 1.0 on Android. As a result, a few devices may not be able to play the game starting October.

We are sorry if you are concerned and we thank you for your understanding that this was unavoidable, as this will help us with graphic improvements in the future.

~ Baskerville